Rollout name as local variable in the scope of the rollout

MAXScript Language Improvements in 3ds Max 5

?

The name of a rollout is now defined as a local variable in the scope of the rollout, as long as the name is not a global variable. This allows for constructs such as:

fn makeDialog =

(

?rollout test "test"

?(?on test open do print (getdialogpos test)

?)

?createdialog test

)

makeDialog()

?

See also

MAXScript Language Improvements in 3ds Max 5